win7iis安装配置出现错误(Win7系统下iis7部署网站配置失败请求跟踪规则的方法)

本文目录
- Win7系统下iis7部署网站配置失败请求跟踪规则的方法
- win7安装iis出现错误
- win7 64位系统启用iis时 出现错误并非所有的功能被成功更改
- win7系统安装IIS出错怎么办
- WIN7安装IIS错误,提示“出现错误 并非所有的功能被成功更改”
- windows7安装iis时 ,说出现错误,并不是所有的功能被更改
- win7新建IIS站点出现错误1068:依赖服务或组无法启动如何解决
- win7系统IIS服务器启动失败显示不支持此接口如何解决
- Win7系统安装IIS7.5后运行asp文件提示500错误
Win7系统下iis7部署网站配置失败请求跟踪规则的方法
在win7系统下使用iis7部署网站的时候,虽然可以配置网站日志来检测网站的运行情况,但是对某些具体的请求光用网站日志是不够的,所以就需要配置失败请求跟踪规则,利用失败请求跟踪功能,可以在出现问题时捕获相应的XML格式的日志,从而无需重现该问题即可开始故障排除,下面给大家带来Win7系统下iis7部署网站配置失败请求跟踪规则的方法如下。
推荐:
1、在win7系统下打开iis,展开“网站”,选中要配置的网站,在功能视图可以看到失败请求跟踪规则,双击“失败请求跟踪规则”,如果没有看到如下图的界面,就点击功能视图来切换;
2、进入“失败请求跟踪规则”的配置界面,可以看到目前还没有配置任何规则;
3、在操作面板点击“添加”来添加规则,这时弹出添加规则的窗口;
4、第一步是选择跟踪的内容,有多种选择。如果要跟踪特定的某类网页或某个网页,可以使用自定义,比如要跟踪ab开头的网页,可以如下图配置;
5、点击“下一步”,这里选择在什么情况下跟踪请求,可以设置状态码,为了便于测试,这里设置状态码404;
6、点击下一步,按默认设置,点击完成即可;
7、默认失败请求跟踪规则是不启用的,所以还要回到步骤一的界面来启用。点击要配置的网站(Test),点击功能视图即可访问步骤一的界面。在操作面板上,点击配置下的“失败请求跟踪……”;
8、在弹出的窗口中,勾选“启用”,点击确认按钮即可。在这里要记下“目录”,这个是要一会用来查看日志的;
9、现在可以访问一个ab开头但是在Test网站中并不存在的网页来验证刚才的配置了。比如访问about2.aspx;
10、打开步骤8记下的目录,可以看到产生了如下文件,双击打开文件,可以看到失败请求的情况;
上面跟大家介绍的是Win7系统下iis7部署网站配置失败请求跟踪规则的方法,有需要的朋友可以参照上面详细的图文步骤进行操作吧,更多精彩内容欢迎继续关站。
win7安装iis出现错误
如此情况,可能是系统有问题了。直接换个验证过的系统盘重装系统就行了,这样就可以全程自动、顺利解决 win7系统中安装IIS出错 的问题了。用u盘或者硬盘这些都是可以的,且安装速度非常快。但关键是:要有兼容性好的(兼容ide、achi、Raid模式的安装)并能自动永久激活的、能够自动安装机器硬件驱动序的系统盘,这就可以全程自动、顺利重装系统了。方法如下:
1、U盘安装:用ultraiso软件,打开下载好的系统安装盘文件(ISO文件),执行“写入映像文件”把U盘插到电脑上,点击“确定”,等待程序执行完毕后,这样就做好了启动及安装系统用的u盘,用这个做好的系统u盘引导启动机器后,即可顺利重装系统了;
2、硬盘安装:前提是,需要有一个可以正常运行的Windows系统,提取下载的ISO文件中的“*.GHO”和“安装系统.EXE”到电脑的非系统分区,然后运行“安装系统.EXE”,直接回车确认还原操作,再次确认执行自动安装操作。(执行前注意备份C盘重要资料!);
3、图文版教程:有这方面的详细图文版安装教程怎么给你?不能附加的。会被系统判为违规的。
重装系统的系统盘下载地址在“知道页面”右上角的…………si xin zhong…………有!望采纳!
win7 64位系统启用iis时 出现错误并非所有的功能被成功更改
win7 64位系统启用iis时 出现错误并非所有的功能被成功更改是设置错误造成的,解决方法为:
1、打开控制面板,在控制面板中找到“程序和功能”,单击弹出“程序和功能”界面。
2、在“程序和功能”界面,点击“打开或关闭Windows功能”选项卡,会弹出Windows功能界面。此过程可能会时间较长,请耐心等待几分钟。
3、在打开的“Windows功能”界面中,可以查看已经打开和关闭的Windows功能。其中前面挑勾的为已经打开的Windows功能,前面未挑勾的为未打开的Windows功能。
4、找到Internet信息服务,打开前面的“+”符号,可以看到Internet信息服务的功能项。根据我们在制作网页的需求,开启FTP服务器、Web管理工具、万维网服务等内容。需要打开的在前面选中。
5、选中之后点击确定,系统提示Window正在更改功能,请稍候。这时候只需要耐心等待即可。系统打开Internet信息服务后自动关闭已经打开的“Windows功能”界面,请放心
6、启动Internet信息服务后,在我的电脑上点击右键,选择“管理”进入计算机管理界面,在此界面点击“服务和应用程序”,可以看到已经打开的Internet信息服务管理器。点击之后可以才Internet信息服务中配置网站等的信息。
win7系统安装IIS出错怎么办
win7系统安装IIS时需要“打开或关闭windows功能”,但是开启“打开或关闭windows功能”显现一片空白,为什么会出现这样情况?由于Windows Modules Installer服务被关闭并禁用,或者注册表被篡改都有可能导致“打开或关闭windows功能”显示一片空白。大家可以通过启动Windows Modules Installer服务、修改注册表或者第三方软件来解决。下面看看详细解决步骤吧。
推荐: win764位纯净版下载
解决方法一:
1、桌面上选中“计算机”,“右击”-“管理”,在“服务和应用程序”中找到“服务”;
2、在“服务”中找到Windows Modules Installer服务,“右击”-“属性”;
3、将“启动类型”改为“自动”,并“启动”此服务,“应用”后“确定”即可;
解决方法二:
1、点击“开始”,在“运行”里输入“regedit”或者直接通过快捷键“win”+“R”调出“运行”输入“regedit”并“确定”;
2、在注册表中找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control; 3、在右边找到“BootDriverFlags”,“右击”-“修改”,将“数值数据”改为ffffffff(十六进制下,8个f)或者4294967295(十进制下)。
解决方法三:
1、在百度搜索“win7优化大师”并下载安装;
2、软件安装好后,点击“开始”里面的“一键修复系统”;
3、弹出如下提示,点击“确定”;
4、修复好之后,重启电脑即可,通过以上三种方式均可以修复“打开或者关闭windows功能”空白问题,修复好后,即可顺利安装IIS。
WIN7安装IIS错误,提示“出现错误 并非所有的功能被成功更改”
1、具体操作方法:点击开始,在程序搜索中输入UAC,回车后则进入UAC控制界面。UAC,用户帐户控制设置如下,这个设置主要是避免Windows7种由于用户帐户权限控制使得有些功能不能正确安装。
2、进入控制面板选择程序和功能,然后在卸载或更改程序的左侧再选择打开或关闭Windows功能项,进入“打开或关闭Windows功能”界面:
在该界面中,将“Internet Information Services可承载的Web核心”和Internet 信息服务的勾选去掉,然后单击确定,等执行完毕后,关闭系统,然后再开机。
3、开机后,重新进入控制面板,进入“打开或关闭Windows功能”界面,按照下图,将“Internet Information Services可承载的Web核心”和“Internet 信息服务”的相关功能选中。并单击确定,正常安装完毕后,不需要重起,但建议重起一次,这样在Windows7下,IIS7.5就成功安装完了。
注意:造成不能正确安装IIS的原因很多,杀毒软件或防火墙设置禁止了,也可能是其他程序占用了某些端口等等,再不行只好重新安装操作系统了。
windows7安装iis时 ,说出现错误,并不是所有的功能被更改
一、会造成此错误原因
1、权限不足;
2、文件路径是否不正确;
二、解决办法如下:
1、单击开始图标打开控制面板。
2、在“控制面板”中选择“卸载程序”。
3、然后选择打开或关闭Windows功能。
4、转到“打开或关闭Windows功能”。在此界面中,删除“可由Internet信息服务托管的Web核心”和Internet信息服务,然后单击“确定”。执行完成后,关闭系统,然后再次打开。
5、开机后,重新进入控制面板,进入“打开或关闭Windows功能”界面,选择“可由Internet信息服务托管的Web核心”和“Internet信息服务”的相关功能。然后单击“确定”,在正常安装完成后,不需要重新启动,但建议重新启动一次,以便在Windows 7下成功安装IIS。
win7新建IIS站点出现错误1068:依赖服务或组无法启动如何解决
大家win7旗舰版上在新建IIS站点的时候,总会遇到这样活那样的问题,最常听到就是新建IIS站点出现Windows无法启动worldwidewebpublishingservice服务(位于本地计算机上)。错误1068:依赖服务或组无法启动,这该怎么处理?接下去小编告诉大家一下解决方法。
具体方法如下:
1、点击“开始”菜单,在文本框中输入“services.msc”命令;
2、在打开的“服务”窗口中找到“WorldWideWebPublishingService”服务,点击“启动”;
3、结果弹出“无法启动worldwidewebpublishingservice服务:错误1068:依赖服务或组无法启动”的错误提示;
4、然后我们再从系统日志中,可看到错误信息;
5、然后我们可以发现,系统中根本没有“WindowsProcessActivationService”这一“服务”。所以然我们必须再通过控制面板的打开和关闭来添加这个服务了。点击“开始”菜单,选择“控制面板”;
6、在打开的"控制面板“窗口中,点击”程序“链接;
7、在打开的窗口中,点击”程序和功能“下的”打开和关闭Windows功能“链接;
8、然后会弹出”Windows功能“对话框,该对话框因要检查系统功能组件,所以需要一定时间;
9、等对话框中出现功能选项的一,我们可以发现,系统中没有勾选上“WindowsProcessActivationService”这一“组件功能”。所以我们勾选上后,单击”确定“按钮即可;
10、好了,安装好后我们再重新打开”服务“窗口,启动相关服务就行了。
以上教程和大家详细介绍win7新建IIS站点出现错误1068:依赖服务或组无法启动的方法,用户需要通过控制面板的打开和关闭重新添加这个服务才能继续创建IIS。
win7系统IIS服务器启动失败显示不支持此接口如何解决
在使用win7系统的时候,难免会遇到故障,最近就有用户想要在系统中做WEB测试,但是IIS服务器启动失败,并提示错误代码显示不支持此接口,该怎么解决呢,接下来为大家分享一下详细的解决方法吧。
出错表现为以下几点:
1、World Wide Web Publishing 服务在请求配置数据库更改通知时遇到问题。数据域包含错误号。
2、初始化 World Wide Web Publishing 服务的配置管理器时出错。数据字段包含错误号。
3、由于错误,World Wide Web Publishing 服务正在退出。数据字段包含错误号。最后出现“World Wide Web Publishing Service 服务因 2147500034 (0x80004002) 服务性错误而停止。
解决方法:
需要注册一大批的DLL:
C:WINNTsystem32shell32.dll
C:WINNTsystem32Browseui.dll
C:WINNTsystem32mshtml.dll
C:WINNTsystem32oleaut32.dll
C:WINNTsystem32ole32.dll
C:WINNTsystem32actxprxy.dll
C:WINNTsystem32urlmon.dll
C:WINNTsystem32shdocvw.dll
注册组件的方法例如 regsvr32 shell32.dll
注册以后在DOS下”IISRESET“重新启动IIS,就成功了。
关于win7系统IIS服务器启动失败显示不支持此接口如何解决就给大家分享到这边了,遇到这样问题的话可以采取上面的措施来解决吧,更多精彩内容欢迎继续关注站。
Win7系统安装IIS7.5后运行asp文件提示500错误
在操作之前确保在你的电脑上IIS配置完成了,而且静态页面可以打开,但是打开ASP就会出现500错误的错误之后再进行下面配置。
1、首先打开计算机界面进入路径“C:WindowsServiceProfilesNetworkServiceAppDataLocal”(或者直接在地址栏输入);
2、然后找到并右击“Temp”文件夹选择属性,在打开的属性界面中切换到“安全”选项卡,选择Authenticated Users这个用户(没有找到这个用户的话依次点:--添加--高级--立即查找--选中Authenticated Users这个用户,确定,勾选“完全控制”,然后点击确定。
3、接着进入Internet信息服务(IIS)管理器(或者直接在开始菜单中搜索IIS就出来了),双击ASP项,展开“行为”项,把“启用父路径”改“Ture”,然后点击“引用按钮即可”。
4、依次打开“开始菜单--控制面板--卸载程序”项;
5、接着选择点击“打开或关闭 Windows 功能”,在弹出来的对话框中展开Internet 信息服务(把自己需要的服务勾上,比如这里需要ASP但不需要FTP),设置完成之后点击确定按钮退出;
6、等待配置完后需要重新启动计算机,然后在系统盘里面就能看到inetpub文件夹了。
7、然后打开浏览器,在浏览器地址栏中输入“localhost”能打开如下页面就说明配置成功,如果不成功的话就返回上面仔细注意检查哪个步骤是否操作错误了。
8、进入“控制面板---管理工具---服务”,找到并双击DistributedTransaction Coordinator,把这个服务设置成自动,并且启动它。
9、配置权限。
第一步是修改网站应用池进程标识为:NetWorkService。
第二步配置连接身份信息,操作步骤如下图所示。(用户名填写系统当前用户的登录用户名,密码填写系统当前用户的登录密码。)
第三步权限配置好了之后,点“连接为”旁的“测试连接”,如果列出的项全是绿色的对钩,没有黄色的感叹号,就说明权限配置好了。如果不配置权限,就会有可能由于权限不足无法访问网站目录哦。
10、注册.NET,如果通过上面的方法还是出现500错误的话,检查一下是不是自己之前是不是先安装了vs,然后才开启的IIS服务,这样会导致IIS中的.NET注册失败,虽然IIS中可以看到,但并未注册,所以会导致500错误。
解决注册方法很简单,在cmd命令提示符中输入该命令即可,在打开的命令提示符窗口中输入"%WINDIR%Microsoft.NETFrameworkv4.0.30319aspnet_regiis.exe"-iru –enable,然后回车即可。
11、等待提示安装成功后,IIS应用程序池中会多出两个。这样就可以成功打开.NET网页了。

更多文章:
手机数据线连接电脑只充电怎么办(数据线连接电脑只能充电怎么回事儿)
2026年10月11日 01:00
教资报名ie系列浏览器怎么调(教师资格证报名浏览器提示不是ie浏览器,怎么回事我用的就是ie浏览器)
2026年10月10日 22:50
qq网吧网关共享(QQ网吧网关怎么登陆,QQ网吧的网管要什么怎么管理)
2026年10月10日 21:10
华硕笔记本bios找不到硬盘启动项(华硕笔记本的bios里的boot选项没有硬盘启动项)
2026年10月10日 20:30





