phpmyadmin执行sql语句报错(phpmyadmin导入sql文件出错,怎么办)

本文目录
- phpmyadmin导入sql文件出错,怎么办
- phpmyadmin下SQL语句错误:#1064 - You have an error in your SQL syntax;
- phpmyadmin导入mysql时报错,1064错误是咋回事
- 用phpmyadmin 导入SQL文件失败,怎么解决
- 还有个问题我进phpmyadmin在里面执行sql 总是提示 “表单内缺少值”sql语句是对的 这个该怎么解决
- 一个62M的SQL数据导入phpmyadmin数据库的错误提示
- 我使用phpMyAdmin在mysql中使用sql语句创建表,总是报错,用工具创建就不会错
- 插入语句写入phpmyadmin里面的SQL为什么会报错
- phpmyadmin 管理mysql时 #1130错误
phpmyadmin导入sql文件出错,怎么办
应该是你的这个sql文件生成时没有选择添加CREATE语句
所以似乎你应该先执行一下下面的SQL语句:
CREATE TABLE qu_setting
(
name varchar(255),
value varchar(255)
)
phpmyadmin下SQL语句错误:#1064 - You have an error in your SQL syntax;
create table user (
id int(4) not null auto_increment primary key,
username varchar(32) not null,
password varchar(32) not null
) ENGINE=MYISAM;
这样就可以了。另外你可以直接用phpmyadmin建表,不用写sql语句了
phpmyadmin导入mysql时报错,1064错误是咋回事
phpmyadmin导入mysql时报错,1064错误是咋回事
mysql错误代码1064表示用户输入的sql语句有语法错误。具体错误位置和内容会在后面的描述中写出,如:
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that
corresponds to your MySQL server version for the right syntax to use near ’这里是用户输入的SQL语句出错点内容’ at line 1
如果想解决这样的错误,需要使用者去参考语法手册和使用规范,并多加练习、应用、体验,才能减少和解决相关错误。
用phpmyadmin 导入SQL文件失败,怎么解决
Phpmyadmin工具导入数据库失败的解决办法
操作步骤:
1、使用文本器editplus打开51php.sql文件,将头部信息全部删除,只保留数据库表信息。
2、删除头部信息后,一般都可以导入成功。如果还不成功,用phpmyadmin的sql语句进行导入,一般都OK的
还有个问题我进phpmyadmin在里面执行sql 总是提示 “表单内缺少值”sql语句是对的 这个该怎么解决
这个问题其实是IE浏览器阻止了弹窗、、IE浏览器烂的一B、、、设置不启用阻止弹窗就行了、、
一个62M的SQL数据导入phpmyadmin数据库的错误提示
KEY
title
等是关键字,最好不要这么用,可以加一下前缀。
CREATE
TABLE
bbs_common_addon(
bubuol_KEY
varchar(
255
)
NOT
NULL
,
bubuol_title
varchar(
255
)
NOT
NULL
,
bubuol_sitename
varchar(
255
)
NOT
NULL
,
bubuol_siteurl
varchar(
255
)
NOT
NULL
,
bubuol_description
varchar(
255
)
NOT
NULL
,
bubuol_contact
varchar(
255
)
NOT
NULL
,
bubuol_logo
varchar(
255
)
NOT
NULL
,
bubuol_system
tinyint(
1
)
NOT
NULL
,
PRIMARY
KEY
(bubuol_
KEY
)
);
试试这个。
还有就是类型的不支持匹配。
我使用phpMyAdmin在mysql中使用sql语句创建表,总是报错,用工具创建就不会错
正确的语句如下:
CREATE TABLE `epet`.`petinfo` (
`pet_id` INT NOT NULL AUTO_INCREMENT,
`pet_name` VARCHAR(50) NULL,
`pet_sex` VARCHAR(10) NULL,
`pet_strength` INT NULL,
`pet_cute` INT NULL,
`pet_love` INT NULL,
`pet_intro` TEXT NULL,
`pet_owner_name` VARCHAR(50) NULL,
`pet_owner_email` VARCHAR(50) NULL,
`pet_password` VARCHAR(50) NULL,
`pet_pic` VARCHAR(50) NULL,
`pet_type` INT NULL,
PRIMARY KEY (`pet_id`)
) ENGINE=MYISAM CHARACTER SET utf8 COLLATE utf8_unicode_ci;
我看了你生成的SQL语句,注意mysql语句各关键字之间的空格,报错的原因就是这个。
在你的语句中,把CHARACTER SET写成了CHARACTERSET,当然报错了,我这是举一个例子
插入语句写入phpmyadmin里面的SQL为什么会报错
.登陆以后,选用你要放的位置。百可以是导入整个数据库,也可以导入某一个表。具体如下图
2.在导入的时候,你可以看到需要导入的模式可以是zip/.sql的。度根据你的配置知会显示具体的数据情况,如下图道的8M.
3.如果你的上传上限是2m.上线显示的是2048,可以在配置文件里进行更改。如下图查找php.in配置文件。
4.在配置文件里用ctrl+f查找,memory_limit,可以将原来的数字2m换成你需要的数据,如下图的128M等 。如果上传时间受限的话,也可以更改最大时间。max-time
5.根据需求导入自己想要专导入的信息,如下图显示,导入成功后也会有属显示,在数据库里就能看到某个导入的数据表。整个数据库。
phpmyadmin 管理mysql时 #1130错误
找到文件my.ini(mysql路径下),找到,添加skip-grant-tables
......
skip-grant-tables
重启mysql,以root用户登录(不需要输入密码)
在sql标签下,运行以下sql语句
flush privileges;
grant all privileges on *.* to root@’localhost’ identified by "你的密码";
到my.ini文件下注释掉之前添加的skip-grant-tables (一定要记得这步)
重启mysql,就可以了

更多文章:
teammate(teammate,company,partner)
2026年10月11日 06:10
javascript arraybuffer(javascript可以把base64编码转换成二进制代码吗求示例代码!)
2026年10月11日 04:00
text函数公式(excel中round和text函数的区别是什么)
2026年10月11日 03:50
google chrome打不开(chrome浏览器打不开怎么回事 浏览器打不开的处理方法)
2026年10月11日 02:00
websocket整合springboot(Springboot整合Websocket遇到的坑)
2026年10月11日 01:40
drawerlayout(android 怎样让drawerlayout设置的侧滑菜单的内容充满屏幕)
2026年10月10日 19:20
xor四位数怎么运算(单片机怎样用C语言实现4个数字间的异或)
2026年10月10日 17:50
perl数组中最多的元素(用perl实现,得到一个数组中重复次数最多的元素)
2026年10月10日 17:00




